summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjnanar2023-11-10 20:34:35 +0100
committerjnanar2023-11-10 20:34:35 +0100
commitfdcd939a6aaa7ffef16043935ac04438199826e9 (patch)
tree9903ae6493d12619b0d135ec3b17109510d0ed41 /PKGBUILD
parentd7cd3e6f56761b28ddeadc2d45a29c56e611c2bf (diff)
downloadaur-python-shortuuid-git.tar.gz
Update PKGBUILD to follow python-shortuuid
https://aur.archlinux.org/packages/python-shortuuid Thanks MarsSeed for his comment.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 971267e9d04a..80842e5150dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,11 @@ arch=(any)
url="https://github.com/skorokithakis/shortuuid"
license=('BSD')
depends=('python')
-makedepends=('git' 'python-setuptools' 'python-installer' 'python-poetry')
+makedepends=(python-{build,installer,wheel}
+ python-poetry-core)
options=(!emptydirs)
provides=('python-shortuuid')
-replaces=('python-shortuuid')
conflicts=('python-shortuuid')
-#optdepends=('')
source=('git+https://github.com/skorokithakis/shortuuid.git')
_gitname="shortuuid"
@@ -30,7 +29,13 @@ build() {
poetry build
}
+check() {
+ cd "$srcdir/$_gitname"
+ python -m unittest discover
+}
+
package() {
- cd "$srcdir/$_gitname"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$srcdir/$_gitname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING
}