summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJochem Broekhoff2024-11-17 15:53:05 +0100
committerJochem Broekhoff2024-11-17 15:53:05 +0100
commitb7983cee9e3a0a9bc9ddd5ef283763679e7105ee (patch)
tree9a73e9b0cae392dce6caede11fb787aeb1428460 /PKGBUILD
parent32866736cdc3227f353ed4f42e8f7d780490f786 (diff)
downloadaur-python-speech-features.tar.gz
Switch to PEP 517 build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f5176bbcb69..f56d573fc145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=python_speech_features
pkgname=python-speech-features
pkgver=0.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="Python Speech Feature extraction"
arch=('any')
license=('MIT')
@@ -10,18 +10,18 @@ url="https://github.com/jameslyons/${_pkgname}"
depends=("python-scipy"
"python-numpy")
-
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("https://github.com/jameslyons/${_pkgname}/archive/${pkgver}.zip")
sha256sums=("30ed2034fb26bc83b2b4a527a4fc45323c5a7674be0ac304f22559acfdb84e37")
build() {
cd $srcdir/$_pkgname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $srcdir/$_pkgname-$pkgver
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
# License
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"