summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTheo J.A. de Vries2015-08-06 11:34:30 +0200
committerTheo J.A. de Vries2015-08-06 11:34:30 +0200
commite8e552bf8953e492fceb0920f763809667367194 (patch)
treea14cbb639484f751bf9321199917daff0a9d119c /PKGBUILD
downloadaur-python-sphinx-testing.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..207108c9c010
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id$
+# Maintainer: vri <t.j.a.devries(at)gmail(dot)com>
+
+# for customization
+_pre=python-
+_pkgname=sphinx-testing
+_ext=
+_basedir=/usr
+
+pkgname=${_pre}${_pkgname}${_ext}
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Testing utility classes and functions for Sphinx extensions"
+arch=(any)
+url="https://pypi.python.org/pypi/sphinx-testing/"
+license=('BSD')
+depends=('python-sphinx' 'python-six')
+#optdepends=()
+makedepends=('python-pip')
+#options=()
+source=(
+ https://pypi.python.org/packages/source/s/${_pkgname}/${_pkgname}-${pkgver}.tar.gz
+ )
+md5sums=(
+ '0292c02299c00c1bf33c86ac50feaa79'
+ )
+
+build() {
+ msg "Nothing to do..."
+}
+
+package() {
+ cd "${srcdir}"
+ /usr/bin/pip install --root="$pkgdir/" "${_pkgname}"
+ install -Dm644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+