summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorobiesmans2015-07-07 20:52:47 +0200
committerobiesmans2015-07-07 20:52:47 +0200
commiteff506da3a5060f288af49ea3db116571ce68473 (patch)
treec331bd0d6daccd78e91ae9f4f96c9d2a8419d4be /PKGBUILD
downloadaur-python-tellcore-py-git.tar.gz
Migration to aur4.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41837f1f9560
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Olivier Biesmans <o.aurlinux@biesmans.fr>
+
+pkgname=python-tellcore-py-git
+pkgver=20130810
+pkgrel=1
+pkgdesc="Python wrapper for Telldus' home automation library."
+arch=('any')
+url="https://pypi.python.org/pypi/tellcore-py"
+license=('GPL3')
+groups=('devel')
+depends=('python')
+makedepends=('python' 'git')
+provides=()
+conflicts=('python-tellcore-py')
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=()
+_gitroot='https://github.com/erijo/tellcore-py.git'
+_gitname=tellcore-py
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: