summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-03-06 20:52:29 +0800
committerChih-Hsuan Yen2022-03-06 20:52:29 +0800
commit77268abd8f735046d663a50bf0c300711d296cfc (patch)
tree1bbcef0abf6fbf68cce9a49fb1fd67fa74b3bd92 /PKGBUILD
parent631895abb21e98d12761dbc601532b4887f22d2f (diff)
downloadaur-python-tensorly.tar.gz
fix dependencies
Also bring fixed tests back - test_hals_nnls and test_active_set_nnls are fixed in version 0.7 https://github.com/tensorly/tensorly/pull/323
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 512d4e101578..3310dfcaf5c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,20 @@
pkgname='python-tensorly'
pkgver=0.7.0
-pkgrel=1
+pkgrel=3
pkgdesc="Simple and Fast Tensor Learning in Python"
arch=('any')
url="https://tensorly.org/stable/home.html"
license=('BSD')
depends=(
python
+ python-numpy
+ python-scipy
)
makedepends=(
python-setuptools
)
optdepends=(
- python-numpy
python-pytorch
python-tensorflow
)
@@ -50,7 +51,7 @@ check() {
# So many flaky tests...
# https://github.com/tensorly/tensorly/issues/310
TENSORLY_BACKEND=$backend pytest -v tensorly \
- -k 'not test_svd and not test_active_set_nnls and not test_tr_tensor and not test_hals_nnls and not validate_tucker_rank and not test_parafac'
+ -k 'not test_svd and not test_tr_tensor and not validate_tucker_rank and not test_parafac'
done
}