summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-03-31 23:46:40 -0500
committerCarlos Aznarán Laos2023-03-31 23:46:40 -0500
commit8cf8c7a8571c7eba59fd0a66bb831b35c664d95c (patch)
tree7d4911c7e6bd56a1f5c93f6185b80810aad4eb39 /PKGBUILD
downloadaur-python-torchdyn.tar.gz
Bump version to 1.4.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35d33fc72603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=torchdyn
+pkgname=python-${_base}
+pkgdesc="A PyTorch library entirely dedicated to neural differential equations, implicit models and related numerical methods"
+pkgver=1.4.0.1
+pkgrel=1
+arch=(any)
+url="https://github.com/DiffEqML/${_base}"
+license=(Apache)
+depends=(python-torchcde python-scikit-learn python-pytorch-lightning python-torchvision python-matplotlib)
+makedepends=(python-build python-installer python-poetry)
+checkdepends=(python-pytest) # python-poethepoet
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('119632764113c7c03300202c3b4bdde138c6b450f60aedf054ba57257e726f011d94638ebb800e4375c54ad1db5c94b14e9bd77d7add86c12a77e500c04196b6')
+
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest test
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}