summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Gehr2024-04-23 14:36:53 +0200
committerStefan Gehr2024-04-23 14:36:53 +0200
commit70539b8d7a59c99135bfe3fd410c392b8e74685f (patch)
tree2555fbfc9132aa800cb10271c52c9e77c117a827 /PKGBUILD
parente6087ecfc6aedc6f30b9f23cf8e307f9a5fee904 (diff)
downloadaur-python-tr064.tar.gz
Use standards based install method
Using https://wiki.archlinux.org/title/Python_package_guidelines#Standards_based_(PEP_517) to build and install the package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1c4b7b1ce73..1314395829e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ arch=(any)
url="https://github.com/bfueldner/tr064"
license=(MIT)
depends=(python-requests python-lxml)
-makedepends=(git python-pip)
+makedepends=(git python-pytest-runner python-wheel)
source=(git+"https://github.com/bfueldner/tr064#commit=6b12f879fa5ccec4cd2d68fac48db1c2815f131c")
b2sums=("SKIP")
build() {
cd $_name
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_name
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}