summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAseem Athale2024-04-29 12:58:18 +0530
committerAseem Athale2024-04-29 12:58:18 +0530
commite84bfc7b1e944f5673ce94d7f7ae975c29b360fe (patch)
tree5e418e82adcf916849d7d494caa6b7403b9a11a0 /PKGBUILD
parent822005193f34c421b55dd6f6248e3bd42611eaad (diff)
downloadaur-python-varname-git.tar.gz
python-varname-git: Fix failing build
`--skip-dependency-check` allows the package to build, and add the proper dependencies to the package. Signed-off-by: Aseem Athale <athaleaseem@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 247acbd98544..20ac049768cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
_pkgname=python-varname
pkgname=${_pkgname}-git
pkgver=0.13.0.r0.gea1ec82
-pkgrel=2
+pkgrel=3
pkgdesc="A Python library to retrieve variable names from functions or classes -- git version"
arch=('any')
url="https://github.com/pwwang/${_pkgname}"
license=('MIT')
-depends=('python')
-makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel' 'python-poetry' 'python-virtualenv' 'python-cachecontrol' 'python-poetry-plugin-export' 'python-jsonschema')
+depends=('python' 'python-executing')
+optdepends=('python-asttokens' 'python-pure-eval')
+makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel' 'python-poetry')
source=("git+${url}.git")
sha512sums=('SKIP')
@@ -24,7 +25,8 @@ prepare() {
build() {
cd "${_pkgname}"
- python -m build --wheel --no-isolation
+ ## skip dependency check because of pinned deps
+ python -m build --wheel --no-isolation --skip-dependency-check
}
package() {