summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo Piccinini2024-05-05 00:52:42 +0200
committerMatteo Piccinini2024-05-05 00:52:42 +0200
commite59f9b0a48b07902947f2dd50620549ba5e968ac (patch)
tree3abe7a1452270f47abe76e14f7544817411b8d41 /PKGBUILD
parent57cf544eefc912dcd190005f9e22ba74236b26c2 (diff)
downloadaur-python-wsgi-intercept.tar.gz
Update source url for future stability of archives and hashes
https://github.blog/2023-02-21-update-on-the-future-stability-of-source-code-archives-and-hashes/
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71af5444a139..87bf7ed9566b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=python-wsgi-intercept
_name=${pkgname#python-}
pkgver=1.13.0
-pkgrel=2
+pkgrel=3
pkgdesc="Intercept socket connection to wsgi applications for testing"
arch=(any)
url="https://github.com/cdent/wsgi-intercept"
@@ -25,9 +25,12 @@ checkdepends=('python-httplib2'
optdepends=('python-httplib2: for intercepting requests of python-httplib2'
'python-requests: for intercepting requests of python-requests'
'python-urllib3: for intercepting requests of python-urllib3')
-provides=("$pkgname")
-source=("$_name-$pkgver.tar.gz::https://github.com/cdent/$_name/archive/refs/tags/v$pkgver.tar.gz")
-b2sums=('522b8149c68ac47c5074714731ac758b67d90199b42b2a30629724c097093b35bb29e34ddc20906141ed0682863910297d88374128544a8f268b347483c7761c')
+source=("$_name-$pkgver.tar.gz::https://api.github.com/repos/cdent/$_name/tarball/refs/tags/v$pkgver")
+b2sums=('57ed44e6dd1bdf70193a4920da15b8e0dd2c5dd41a61efedf6f9aaf4778114519c7766dec9a3f42690dce4be061785fd62c1f1e847d9d6f034dfe1846b454f19')
+
+prepare() {
+ tar zxvf "$_name-$pkgver.tar.gz" --strip-components=1 --one-top-level
+}
build() {
cd "$_name-$pkgver"
@@ -48,5 +51,4 @@ package() {
install -Dm 644 README -t "$pkgdir/usr/share/$pkgname/"
install -Dm 644 "build/sphinx/${_name//-/_}.1" -t "$pkgdir/usr/share/man/man1/"
rm -frv "$pkgdir/$site_packages/${_name//-/_}/tests/"
-
}