summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-05-08 22:59:58 +0200
committerBenjamin Chrétien2016-05-08 22:59:58 +0200
commit8f30204b46c05691ef4b5857c06ff4a635a779c4 (patch)
treed4edb48e5feb61b26d0a318b6dac3e52a6bd503b /PKGBUILD
downloadaur-python2-matplotlib2tikz.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d27de52a99d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Kashif <kashifb+aur@gmail.com>
+pkgname=python2-matplotlib2tikz
+pkgver=0.5.7
+pkgrel=1
+pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
+url="https://github.com/nschloe/matplotlib2tikz"
+depends=('python2' 'python2-numpy' 'python2-matplotlib>=1.4.0' 'python2-pillow')
+makedepends=('python2')
+license=('MIT')
+arch=('any')
+source=("https://github.com/nschloe/matplotlib2tikz/archive/v${pkgver}.tar.gz")
+sha256sums=('b5378b947c1d7ce3eb30c3bf4a5e4a9034a623d3d4d38b6e10b43c3cd0f083d7')
+
+build() {
+ cd "${srcdir}/matplotlib2tikz-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/matplotlib2tikz-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}