summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Coolen2016-10-10 14:42:19 -0400
committerMark Coolen2016-10-10 14:42:19 -0400
commit69494e4685ce765ac7b83d86bc005c39b95b3110 (patch)
treeaa61638066be0d4072fe75d96c40dfeb5e93d1f5 /PKGBUILD
downloadaur-python2-mingus.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f2d152dc4a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mark Coolen <mark dot coolen at gmail dot com>
+pkgname=python2-mingus
+_pkgname=python-mingus
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="a package for Python used by programmers, musicians, composers and researchers
+to make and investigate music."
+arch=('any')
+url="https://github.com/bspaans/python-mingus"
+license=('GPL')
+depends=('python2')
+optdepends=('lilypond' 'fluidsynth')
+source=("https://github.com/bspaans/python-mingus/archive/${pkgver}.tar.gz")
+options=(!emptydirs)
+md5sums=('95aff384c90f8b06345b67dc922740c9')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd "$pkgdir/usr"
+ mv mingus_examples lib/python2.7/site-packages/mingus/examples
+}