summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Willemse2016-02-14 23:57:17 +0100
committerTom Willemse2016-02-14 23:57:17 +0100
commit491309b44bf9ef6a89923d97fd2b3faac53cacc8 (patch)
tree8bb20c031849f19159977f26a0e39f5205263d09 /PKGBUILD
downloadaur-python2-pycommand.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bab8b293f46d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tom Willemse <tom@ryuslash.org>
+
+_python=python2
+_name=pycommand
+
+pkgname=$_python-pycommand
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A clean and simplistic alternative for argparse, optparse and getopt"
+depends=('python2')
+makedepends=('python2-distribute')
+arch=('any')
+source=("http://pypi.python.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('2d8197b987c5096ae5646f0155f1aa1d')
+url="https://pypi.python.org/pypi/pycommand"
+license=('custom:ISC')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ $_python setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}