summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Monfils2019-04-16 10:45:26 +0200
committerNathan Monfils2019-04-16 10:47:12 +0200
commit7970d1bae9a8fb15e872ccfbcf7e5938b37d8bb4 (patch)
tree4e00510ce1dccde1e1d972ebfb70797b0541748e /PKGBUILD
downloadaur-python2-revdb-hg.tar.gz
Created package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c048f302bf75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nathan Monfils <nathan.monfils@hotmail.fr>
+
+pkgname=python2-revdb-hg
+pkgver=r48.f34e846835e3
+pkgrel=1
+pkgdesc="RevDB, the Reverse Debugger"
+arch=(any)
+url="https://bitbucket.org/pypy/revdb"
+license=('UNKNOWN')
+depends=('pypy2-revdb')
+makedepends=(python2-setuptools mercurial)
+provides=("${pkgname%-hg}")
+conflicts=("${pkgname%-hg}")
+source=("${pkgname}::hg+https://bitbucket.org/pypy/revdb")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ python2 setup.py install --skip-build -O1 --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/python*/site-packages/tests
+}
+