summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Saavedra Vaz2023-03-15 10:38:40 -0300
committerLucas Saavedra Vaz2023-03-15 10:38:40 -0300
commit3baf016bed984b69686ad2baa55b7d5290aea57e (patch)
tree639b2b885db8333012c8ef825d0d6c2c6904c265 /PKGBUILD
parentdb20ce646b9cd73bfc5280cf10a2105f277b37b4 (diff)
downloadaur-qemu-esp-xtensa-git.tar.gz
Fix paths and dependencies
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa41aefe4533..75252133ba29 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Lucas Saavedra Vaz <lucas.vaz at espressif dot com>
+# Maintainer: Christian Heusel <christian at heusel dot eu>
pkgname="qemu-esp-xtensa-git"
_gitname="qemu"
-pkgver=r97829.0152246eb3
-pkgrel=2
+pkgver=r99808.31099a4e5c
+pkgrel=1
pkgdesc="Espressif's fork of QEMU with support for ESP32 xtensa boards. Git version."
arch=("x86_64")
url="https://github.com/espressif/qemu"
license=("GPL2")
-depends=("glib2" "dtc" "pixman" "zlib" "bzip2" "python" "libgcrypt" "pcre")
-makedepends=("gcc" "git" "ninja")
+depends=("glib2" "dtc" "pixman" "systemd-libs" "libseccomp" "gnutls" "libbpf")
+makedepends=("gcc" "git" "ninja" "python")
provides=("qemu-esp-xtensa")
conflicts=("qemu-esp-xtensa")
options=("!buildflags" "!makeflags")
@@ -24,7 +25,7 @@ build() {
cd "$srcdir/${_gitname}"
./configure \
--target-list=xtensa-softmmu \
- --prefix=/opt/${pkgname} \
+ --prefix=${pkgdir}/opt/${pkgname} \
--enable-gcrypt \
--enable-debug \
--enable-sanitizers \
@@ -41,6 +42,7 @@ package() {
cd "$srcdir/${_gitname}/build"
ninja install
mkdir -p ${pkgdir}/usr/bin
+ chmod +x ${pkgdir}/opt/${pkgname}/bin/qemu-system-xtensa
ln -s /opt/${pkgname}/bin/qemu-system-xtensa ${pkgdir}/usr/bin/qemu-esp-xtensa
}