summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciej Suminski2022-10-03 20:20:32 +0200
committerMaciej Suminski2022-10-03 20:20:32 +0200
commit99391d6896d8acf88f34127ea55b5b30144fb9bb (patch)
treef011b67eccac3a91369df64a799e8f51b7192357 /PKGBUILD
parent452ecb8b1e867f9b4b2a6059a5bea50ea53e5c31 (diff)
downloadaur-qjackctl-git.tar.gz
Update
Disabled Qt6 builds Fixed depends tag (portaudio vs qt5-x11extras) Switched the build type to release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 454b23bd4a00..a80ba872911e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgrel=1
pkgdesc="A Qt front-end for the JACK low-latency audio server"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('jack' 'hicolor-icon-theme' 'qt5-x11extras')
+depends=('jack' 'hicolor-icon-theme' 'portaudio')
url="https://qjackctl.sourceforge.io/"
makedepends=('cmake' 'git' 'qt5-tools')
provides=('qjackctl')
@@ -27,7 +27,8 @@ pkgver() {
build() {
cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCONFIG_QT6=OFF \
-S "$srcdir/${pkgname}"
cmake --build build
}