summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavide Depau2020-07-11 13:58:26 +0200
committerDavide Depau2020-07-11 13:58:26 +0200
commit4c71d398331ec70f0046f8da854d72c7c11cacf2 (patch)
tree65cf1042198c6d3acef136d5733a4672eb571412 /PKGBUILD
downloadaur-qt5-gtkplatform-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..689a5b747402
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Davide Depau <davide@depau.eu>
+
+_pkgname=qt5-gtkplatform
+pkgname=$_pkgname-git
+pkgver=0.2.4.r11.g1149f4f
+pkgrel=1
+pkgdesc="Run Qt applications using GTK+ as a windowing system"
+arch=('x86_64')
+depends=('qt5-base' 'gtk3' 'libnotify')
+makedepends=('make')
+url="https://github.com/CrimsonAS/gtkplatform"
+license=('GPL2' 'GPL3' 'LGPL3' 'custom')
+source=(${_pkgname}::git+https://github.com/CrimsonAS/gtkplatform.git)
+sha256sums=('SKIP')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT="$pkgdir/" DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}