summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 00:45:09 +0800
committerSukanka2022-06-07 00:45:09 +0800
commitd835602603fe5797b3b170ae2d5e93fb250a470e (patch)
treeb9f37dcbf320d7a2676b67a8c9f88309798ef38a /PKGBUILD
downloadaur-r-stanova.tar.gz
add r-stanova
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4cfdf3a7fcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+#Maintainer: sukanka <su975853527 AT gmail.com>
+_pkgname=stanova
+_pkgver=0.3-0
+pkgname=r-${_pkgname,,}
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Bayesian Models with Categorical Variables"
+arch=('x86_64')
+url="https://github.com/bayesstuff/${_pkgname}"
+license=('LGPL3')
+depends=(r
+ r-lme4
+ r-coda
+ r-rstan
+ r-emmeans
+)
+makedepends=(git)
+optdepends=(
+ r-testthat
+ r-rstanarm
+ r-brms
+ r-memss
+ r-afex
+ r-glmmtmb
+ r-bayesplot
+ r-tibble
+ r-tidybayes
+ r-tidyverse
+)
+source=("git+https://github.com/bayesstuff/${_pkgname}.git")
+sha256sums=('SKIP')
+
+
+build() {
+ mkdir -p ${srcdir}/usr/lib/R/library
+ R -e "install.packages('${srcdir}/${_pkgname}',\
+ type='source', repos=NULL,lib='${srcdir}/usr/lib/R/library', INSTALL_opts='--no-multiarch --no-docs --no-test-load')"
+}
+
+package() {
+ cp -a --no-preserve=ownership "${srcdir}/usr" "${pkgdir}"
+}