summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:17:10 +0800
committerSukanka2022-06-07 02:17:10 +0800
commitb341c078b2b8be9cca43ea13a4e6fe5cc52142e3 (patch)
treee114e1315959a52a4c3c7603357c83e4f9e6912c /PKGBUILD
downloadaur-r-txdb.hsapiens.ucsc.hg19.knowngene.tar.gz
add r-txdb.hsapiens.ucsc.hg19.knowngene
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db32997b4142
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TxDb.Hsapiens.UCSC.hg19.knownGene
+_pkgver=3.2.2
+pkgname=r-${_pkgname,,}
+pkgver=3.2.2
+pkgrel=4
+pkgdesc='Annotation package for TxDb object(s)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-genomicfeatures
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('063de2b1174782a0b2b8ab7f04a0bdf3c43252cb67c685a9f8ef2b8e318352e9')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: