summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorburdoto2023-05-23 19:57:46 +0200
committerburdoto2023-05-23 21:11:13 +0200
commitd904c7f4ebc4109f9fb87560870193a5fb79327d (patch)
tree84c8f1692a1ea0685c1c2e75b98b2920367fa4ec /PKGBUILD
downloadaur-redir-git.tar.gz
Initial commit
Revert "Update publish.sh" This reverts commit fd4ebcb7a2d9098e156349274fb0dfbe38161e0a. Update publish.sh SRCINFO Update publish.sh chmod Update PKGBUILD Update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e39acc8ace6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tobias Burdow <kaleidox@comroid.org>
+
+pkgname=redir-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Standard IO redirection to Socket"
+arch=('any')
+url="https://github.com/comroid-git/redir"
+license=('GPL-3.0')
+depends=('dotnet-runtime-6.0')
+makedepends=('dotnet-sdk-6.0')
+source=("git+https://github.com/comroid-git/redir.git" "git+https://github.com/comroid-git/csapi.git")
+md5sums=('SKIP' 'SKIP')
+options+=("!strip")
+
+build() {
+ cd redir
+ dotnet publish -c Release --use-current-runtime
+}
+
+package() {
+ install -Dm755 "redir/redir/bin/Release/net6.0/linux-x64/publish/redir" "$pkgdir/usr/bin/redir"
+}