summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorleafly2018-10-28 03:29:11 +0200
committerleafly2018-10-28 03:29:11 +0200
commit76f9592da4ab6f0f7d3d8bff725428fddfa18d19 (patch)
treea8af959dfefdae2191e528f48588b10237b1718e /PKGBUILD
downloadaur-reflow-git.tar.gz
Initial ver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21b6fd69ba41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: leafly <leafly@tuta.io>
+pkgname=reflow-git
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Route any network connection to proxies with flexible rules"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/net-reflow/reflow"
+license=('GPL3')
+provides=("reflow")
+makedepends=('cargo-nightly' 'git')
+conflicts=('reflow')
+source=("$pkgname::git+https://github.com/net-reflow/reflow")
+sha1sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ if command -v rustup > /dev/null 2>&1; then
+ rustup run nightly \
+ cargo build --release
+ else
+ cargo build --release
+ fi
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "target/release/reflow" "$pkgdir/usr/bin/reflow"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+}