summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2020-05-18 16:48:44 +0200
committerPhilip Goto2020-05-18 16:48:44 +0200
commit554d107d8c4e29f7824b3a5ee14a74dac3a7b788 (patch)
treecf7dc7424da9d420242c1995607976254730a1e4 /PKGBUILD
parent130f1bfc9cddcf723df75c26ff524d85d08de31b (diff)
downloadaur-remotely.tar.gz
Update url, desc and check
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3193fd71245..a2e0aef7f765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=remotely
pkgver=1.0
-pkgrel=1
-pkgdesc="A GTK3 VNC Client"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="https://gitlab.gnome.org/haecker-felix/Remotely"
-license=('GPL3')
-depends=('gtk-vnc')
-makedepends=('meson' 'vala')
+pkgrel=2
+pkgdesc="simple VNC viewer for the GNOME desktop environment"
+arch=(i686 x86_64 armv7h aarch64)
+url="https://gitlab.gnome.org/World/Remotely"
+license=(GPL3)
+depends=(gtk-vnc)
+makedepends=(meson vala)
source=("https://gitlab.gnome.org/World/Remotely/-/archive/v${pkgver}/Remotely-v${pkgver}.tar.gz")
-md5sums=('35b9d43f36fbb743de7b8819f0981d10')
+sha256sums=('d4f849388dcecc0f1206d6a8ec897b92239149861334327d45145d699ffdbaf8')
build() {
@@ -18,6 +18,10 @@ build() {
ninja -C build
}
+check() {
+ meson test -C build --print-errorlogs
+}
+
package() {
- DESTDIR="$pkgdir/" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}