summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-02-25 18:20:11 +0900
committerBenjamin Chrétien2016-02-25 18:20:11 +0900
commit33313f1f63806df9e96dd8862de33504e3d7e1a1 (patch)
tree7e583ed01c3b945e6d2e0b6a48dd0b4ed53d7c5a /PKGBUILD
downloadaur-ros-jade-kdl-parser-py.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d08667c463ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The Kinematics and Dynamics Library (KDL) defines a tree structure to represent the kinematic and dynamic parameters of a robot mechanism."
+url='http://ros.org/wiki/kdl_parser_py'
+
+pkgname='ros-jade-kdl-parser-py'
+pkgver='1.11.10'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-jade-rostest
+ ros-jade-urdf
+ ros-jade-orocos-kdl
+ ros-jade-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ python2-catkin-pkg)
+
+ros_depends=(ros-jade-urdfdom-py
+ ros-jade-urdf
+ ros-jade-orocos-kdl
+ ros-jade-python-orocos-kdl)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/jade/kdl_parser_py/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/robot_model-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="robot_model-release-release-jade-kdl_parser_py-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/robot_model-release/archive/release/jade/kdl_parser_py/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('f4df0c8955fa64aa5dd96e2c639c2cd153bdbf75b4e933df5965c800b066a86b')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/jade/setup.bash ] && source /opt/ros/jade/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/jade \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}