summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2023-08-08 12:19:05 +0200
committerMarcell Meszaros2023-08-08 12:19:05 +0200
commitc8e756ecbb9cff145df23b15dd41c2414f7f9e2a (patch)
treee7442f1654b2f917b1d9cf882efefff6e7550efc /PKGBUILD
parentc0c2b4c7d8a15928c8ff8a0fdaab9699d1332571 (diff)
downloadaur-ros-melodic-catkin.tar.gz
0.7.29-2: remove using the unneeded py3 variant of ros-build-tools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47c71e0b9008..2d4002dc2af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@ url='https://www.wiki.ros.org/catkin'
pkgname='ros-melodic-catkin'
pkgver='0.7.29'
-epoch=1
+epoch='1'
arch=('any')
-pkgrel=3
+pkgrel='2'
license=('BSD')
ros_makedepends=(
@@ -30,7 +30,7 @@ depends=(
python-empy
gmock
python
- ros-build-tools-py3
+ ros-build-tools
)
_dir="catkin-${pkgver}/"
@@ -53,9 +53,6 @@ build() {
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \