summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormajor2020-01-08 17:43:31 +0000
committermajor2020-01-08 17:43:31 +0000
commit0afbfaa251c77932ee667da8ee1afc81909e5368 (patch)
treebb8120fbb2eda550bf82c8a65d0db64babe22588 /PKGBUILD
downloadaur-ros-melodic-nmea-msgs.tar.gz
initial commit with adjusted kinetic package (changes python2 to python3, kinetic to melodic)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ed1d785d50f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The nmea_msgs package contains messages related to data in the NMEA format."
+url='http://ros.org/wiki/nmea_msgs'
+
+pkgname='ros-melodic-nmea-msgs'
+pkgver='1.1.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-std-msgs
+ ros-melodic-catkin
+ ros-melodic-message-generation)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-std-msgs
+ ros-melodic-message-runtime)
+depends=(${ros_depends[@]})
+
+_tag=release/melodic/nmea_msgs/${pkgver}-${_pkgver_patch}
+_dir=nmea_msgs
+source=("${_dir}"::"git+https://github.com/ros-drivers-gbp/nmea_msgs-release.git#tag=${_tag}")
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=-python3.8 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}