summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Hague2019-03-23 15:37:25 +0000
committerMatthew Hague2019-03-23 15:37:25 +0000
commit2909dbc3989dbfa64df499114de45dff4a1b51f9 (patch)
treeedb3f60400edf2ce6ec1614a7ace5254cb2dd869 /PKGBUILD
downloadaur-simplescreenrecorder-wlroots-git.tar.gz
Initial commit of package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b9491e22470
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Matthew Hague <matthewhague@zoho.com>
+# Maintainer: Max Mazurov <fox.cpp@disroot.org>
+# Based on PKGBUILD/install by: Maarten Baert <maarten-baert@hotmail.com>
+
+pkgname=simplescreenrecorder-wlroots-git
+pkgver=0.3.11.r23.g4b288cb
+pkgrel=1
+pkgdesc="Experimental fork of simplescreenrecorder with added Wayland support"
+arch=("x86_64")
+url="https://github.com/foxcpp/ssr-wlroots"
+license=("GPL3")
+depends=("qt5-base" "qt5-x11extras"
+ "ffmpeg" "alsa-lib" "libpulse" "jack" "libgl" "glu"
+ "libx11" "libxext" "libxfixes" "libxi"
+ "desktop-file-utils" "gtk-update-icon-cache"
+ "wayland")
+makedepends=("git" "cmake" "qt5-tools" "wayland-protocols")
+source=("git+https://github.com/foxcpp/ssr-wlroots")
+md5sums=("SKIP")
+conflicts=("simplescreenrecorder" "simplescreenrecorder-git")
+provides=("simplescreenrecorder")
+
+install=simplescreenrecorder-wlroots-git.install
+
+pkgver() {
+ cd ssr-wlroots
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+prepare() {
+ cd ssr-wlroots
+ mkdir -p build
+}
+build() {
+ cd ssr-wlroots/build
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_INSTALL_LIBDIR="lib" -DCMAKE_BUILD_TYPE=Release -DWITH_QT5=TRUE ..
+ make
+}
+package() {
+ cd ssr-wlroots/build
+ make DESTDIR="$pkgdir" install
+}