summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsaravanan palanisamy2020-11-27 21:10:43 +0400
committersaravanan palanisamy2020-11-27 21:10:43 +0400
commitf7dbae919c7593a6c52c53126fa163a1ff8f0c9d (patch)
tree7c0372d976456599e7d5902a5c021f151276f944 /PKGBUILD
downloadaur-solokey-full-disk-encryption.tar.gz
add solokey-luks package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62ef78b3ba02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=solokey-full-disk-encryption
+pkgver=r39.ee0359d
+pkgrel=1
+pkgdesc='Use SoloKey to unlock a LUKS partition'
+arch=('any')
+url='https://github.com/saravanan30erd/solokey-full-disk-encryption'
+license=('Apache')
+depends=('fido2luks' 'cryptsetup')
+makedepends=('git')
+backup=('etc/skfde.conf')
+source=('git+https://github.com/saravanan30erd/solokey-full-disk-encryption.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}