summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Rødseth2017-08-30 09:19:40 +0200
committerAlexander F Rødseth2017-08-30 09:20:14 +0200
commit124201a31b6cd3c013e85ab61fa0d3a97c93f736 (patch)
treeaa258aaafcf3d52e202df925f7dcc7cc4677c7ee /PKGBUILD
downloadaur-soundpipe-dev.tar.gz
Add development version of Soundpipe
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6b037e4a954
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Teteros <teteros@openmailbox.org>
+
+pkgname=soundpipe-dev
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='Lightweight music DSP library'
+arch=('x86_64' 'i686')
+url='http://paulbatchelor.github.io/proj/soundpipe.html'
+license=('MIT')
+makedepends=('libsndfile' 'git')
+source=("git+https://github.com/PaulBatchelor/Soundpipe#commit=3946d5b77f8e2e812b919d547518b896b1439554")
+md5sums=('SKIP')
+
+build() {
+ make -C Soundpipe
+}
+
+package() {
+ PREFIX="$pkgdir/usr" make -C Soundpipe install -e
+ install -Dm644 Soundpipe/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:ts=2 sw=2 et: