summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoel Grunbaum2022-10-07 01:47:37 +0000
committerJoel Grunbaum2022-10-07 01:47:37 +0000
commitea8c8cb6c84c9329e93cffe247215379b034cf25 (patch)
tree6dd4fe7c0c76daeb195c65d6cdf7e08c6501bd90 /PKGBUILD
downloadaur-spek-x-git.tar.gz
Created package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffa5c9d472e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Joel Grunbaum <joelgrun@gmail.com>
+
+pkgname=spek-x-git
+pkgver=v0.9.0.r2.g5ed0a19
+pkgrel=1
+pkgdesc='Acoustic spectrum analyser forked from spek.'
+arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
+license=('GPL3')
+depends=('ffmpeg' 'wxgtk3')
+makedepends=('git' 'pkgconfig' 'automake' 'intltool' 'gettext')
+url='https://github.com/MikeWang000000/spek-X'
+conflicts=('spek')
+provides=('spek')
+source=('spek-x-git::git+https://github.com/MikeWang000000/spek-X')
+md5sums=('SKIP')
+options=()
+
+pkgver() {
+ cd $pkgname
+ git describe --long 2>/dev/null | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR=$pkgdir install
+}