summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2021-03-31 16:05:51 +0200
committerPellegrino Prevete2021-03-31 16:05:51 +0200
commita3c1846b3a5afd3a4a21b392f8014e68150fb679 (patch)
tree4d9c9d4a7e1db04b8e23d66ebd22ad5677444d12 /PKGBUILD
downloadaur-stear-keyboard-git.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b37549b2d493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+_pkgname=stear-keyboard
+pkgname=$_pkgname-git
+pkgver=0.1
+pkgrel=2
+pkgdesc="Simple remote keyboard"
+arch=('any')
+url="https://gitlab.gnome.org/tallero/stear-keyboard"
+license=(AGPL3)
+depends=(python-appdirs python-keyboard python-gnupg python-setproctitle)
+source=("git+https://gitlab.gnome.org/tallero/$_pkgname")
+conflicts=("stear-keyboard")
+provides=("stear-keyboard")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+package() {
+ cd $_pkgname
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+}