summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOrhun Parmaksız2021-11-24 22:54:39 +0300
committerOrhun Parmaksız2021-11-24 22:54:39 +0300
commitf9c8a25f7f44dc1492c1dbcfb4880f63509d2dea (patch)
tree25c466dc5ac18b152eb37d7a76a654c5d7720f8e /PKGBUILD
parent5d0bfc3add45f614998975a231bac929b775717c (diff)
downloadaur-stegify.tar.gz
upgpkg: stegify 1.2-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 162672870a1f..140c0532e1d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=stegify
pkgdesc="Tool for LSB steganography written in Go"
pkgver=1.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/DimitarPetrov/stegify"
license=('MIT')
@@ -20,7 +20,8 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go get -d ./...
+ go mod init github.com/DimitarPetrov/stegify
+ go get github.com/DimitarPetrov/stegify/steg
go build -o "$pkgname" .
}