summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Latorre2018-01-19 02:59:18 +0100
committerOscar Latorre2018-01-19 03:04:42 +0100
commit8dad100c5e2c22ff9e6e48268e026e4069fc0816 (patch)
treee8f98f1f4babe9e4ce6da8556f62b43171007702 /PKGBUILD
downloadaur-stegsnow.tar.gz
20131606-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..432cd6cda753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=stegsnow
+pkgver='20130616'
+pkgrel=1
+pkgdesc="The program SNOW is used to conceal messages in ASCII text by appending whitespace to the end of lines."
+url="http://www.darkside.com.au/snow/"
+license=('Apache 2.0')
+arch=('any')
+provides=('stegsnow')
+source=(
+ git+"https://anonscm.debian.org/git/collab-maint/stegsnow.git"
+ "stegsnow.patch"
+)
+md5sums=(
+ "SKIP"
+ "3fc8c6e36aec935e1c5c2ff4ab428500"
+)
+
+build() {
+ cd "$srcdir/stegsnow"
+ git apply "../stegsnow.patch"
+ make
+}
+
+package() {
+ cd "$srcdir/stegsnow"
+ install -D -m755 "stegsnow" "$pkgdir/usr/bin/stegsnow"
+ install -D -m644 "stegsnow.1" "$pkgdir/usr/share/man/man1/stegsnow.1"
+}