summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcyrozap2019-09-05 02:57:02 -0500
committercyrozap2019-09-05 02:57:02 -0500
commit23346b33ecd138fcfe5519d8f1b893a565f7f6ff (patch)
treee2f6ed9fa42f51cb024ba8e48d23aa84324be278 /PKGBUILD
parent410342e8e893c74b205b70f9a1ab5f6de8083b01 (diff)
downloadaur-stp.tar.gz
Update to version 2.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bb6b8ac1a1b..78a55182bc44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,37 @@
# Maintainer: Forest Crossman <cyrozap at gmail dot com>
pkgname=stp
-pkgver=2.1.2
+pkgver=2.3.3
pkgrel=1
pkgdesc="Simple Theorem Prover"
arch=('i686' 'x86_64')
url="https://stp.github.io/"
license=('MIT')
-depends=('bison' 'boost' 'flex' 'minisat-git')
+depends=('bison' 'boost' 'cryptominisat5' 'flex' 'minisat-git' 'python2')
makedepends=('cmake' 'git')
source=("https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
- 'cmake-git.patch')
-sha256sums=('d7f118324a534cfa33cabe7302e717f960a3d29e01c5cabc9232d21683f0085d'
- 'cedc57c9e375b145dcd9f3586505477737315194e260de0f689b7715b2088312')
+ 'mandir.patch')
+sha256sums=('ea6115c0fc11312c797a4b7c4db8734afcfce4908d078f386616189e01b4fffa'
+ '4c09301c5a36cd89845a7177e1215008f8bbb23fa6f3c6cc941006825e28c327')
prepare() {
- cd "$srcdir"
+ cd "$srcdir/$pkgname-$pkgver"
- # Since we're installing from a release archive, searching for a Git
- # directory can cause the build to fail.
- patch -p1 < cmake-git.patch
+ # Correct the destination for man documentation.
+ patch < "$srcdir/mandir.patch"
}
build() {
cd "$srcdir/$pkgname-$pkgver"
+
mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_PYTHON_INTERFACE=ON \
+ ..
make
}