summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorthisirs2021-04-18 17:29:00 +0200
committerthisirs2021-04-18 17:29:00 +0200
commit36cf30f0c236937c4188aa16962e8120b47fad92 (patch)
tree31136d5339660cf53a88be96db195a26ab42a908 /PKGBUILD
parentb52ce835a855e8614fab7133bb9dc9d8d6b580fb (diff)
downloadaur-synology-cloud-station-drive.tar.gz
Add Wayland compatibility (thanks @evybongers)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6a890422849..02ac32bbbdc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,15 @@ pkgname=synology-cloud-station-drive
_iver=4469
_rver=4.3.3
pkgver=$_rver.$_iver
-pkgrel=1
+pkgrel=2
pkgdesc='An application which sync files between your computers and Synology NAS'
arch=('i686' 'x86_64')
url='https://www.synology.com/en-global/releaseNote/CloudStationDrive'
license=('custom')
-optdepends=('nautilus: Nautilus integration')
+optdepends=('nautilus: Nautilus integration'
+ 'xorg-xwayland: Support running under Wayland')
+source=("force-x11.patch")
+md5sums=('a276cb536c6cbe1f39c88c8ee469f9c7')
source_i686=("https://global.download.synology.com/download/Tools/CloudStationDrive/$_rver-$_iver/Ubuntu/Installer/i686/synology-cloud-station-drive-$_iver.i686.deb")
md5sums_i686=('650cffb6a925d79e350e0ae52d94b718')
source_x86_64=("https://global.download.synology.com/download/Tools/CloudStationDrive/$_rver-$_iver/Ubuntu/Installer/x86_64/synology-cloud-station-drive-$_iver.x86_64.deb")
@@ -20,6 +23,7 @@ md5sums_x86_64=('2abfd45014589f1818c87050f70ea90e')
prepare() {
cd "$srcdir"
tar -xJf "$srcdir"/data.tar.xz
+ patch -p1 < force-x11.patch
}
package() {