summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDmytro Kostiuchenko2015-07-06 17:12:07 +0200
committerDmytro Kostiuchenko2015-07-06 17:12:07 +0200
commit4e66052b63033ad787026477dc86ff0cbf0e694d (patch)
treeb1e99f1f289a533c8f3b5b2b6d9ad15298551f83 /PKGBUILD
downloadaur-systemd-kdemodules-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cfed9c5bc881
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: edio <edio at archlinux dot us>
+
+pkgname=systemd-kdemodules-git
+pkgver=20130310
+pkgrel=1
+pkgdesc="systemd units to load KDE modules in your custom environment"
+arch=('any')
+url="https://github.com/edio/systemd-kdemodules"
+license=('GPL3')
+depends=('systemd' 'dbus' 'kdebase-runtime')
+makedepends=('git')
+install='systemd-kdemodules.install'
+
+_gitroot="https://github.com/edio/systemd-kdemodules.git"
+_gitname="systemd-kdemodules"
+
+build () {
+ cd "${srcdir}"
+
+ msg "Connecting to the GIT server..."
+ if [ -d ${_gitname} ] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot} ${_gitname}
+ cd ${_gitname}
+ fi
+ msg "GIT checkout done."
+}
+
+
+package() {
+ cd "${srcdir}"/${_gitname}
+ install -d ${pkgdir}/usr/lib/systemd/user
+ cp *.service ${pkgdir}/usr/lib/systemd/user/
+ cp *.target ${pkgdir}/usr/lib/systemd/user/
+}
+
+# vim: ts=2 sw=2 et: