summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Tran2021-07-28 16:40:40 +1000
committerVictor Tran2021-07-28 16:40:40 +1000
commit8b060b341990594f46066f508deaa27fa1375981 (patch)
tree76c7a697136c8e429199f96b2cb6b4acaac0c920 /PKGBUILD
parentcd3054e084670322dfd8b43e978a9080d3830fa3 (diff)
downloadaur-theshell.tar.gz
Update to 8.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27e563d39ac6..c6c4f578fdb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theshell
-pkgver=8.0.1
+pkgver=8.0.2
pkgrel=0
pkgdesc="Desktop Shell that gets out of your way"
arch=("x86_64")
@@ -12,11 +12,10 @@ depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin'
'libcups' 'qt5-base' 'ts-qtplatform' 'qt5-charts'
'qt5-location' 'kscreen' 'ts-bt' 'ts-bugreport')
optdepends=('alsa-utils: for volume controls')
-makedepends=('git')
conflicts=('ts-startsession' 'ts-polkitagent')
replaces=('ts-startsession' 'ts-polkitagent')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=master')
-md5sums=('SKIP')
+source=('https://github.com/vicr123/theshell/archive/refs/tags/v8.0.2.tar.gz')
+sha256sums=('00bf5d9838eae954f505143a6530d13f67938d0d3a7c5333971e4cb1b50cc615')
build() {
cd "$pkgname-$pkgver"
@@ -26,5 +25,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make install INSTALL_ROOT=$pkgdir
+ make -i install INSTALL_ROOT=$pkgdir
+ chmod u+s $pkgdir/usr/lib/ts-mousepass-change
}