summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6d2c7ec15d5..6f7d6f9441df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = theshell
pkgdesc = Desktop Shell that gets out of your way
- pkgver = 8.0.1
+ pkgver = 8.0.2
pkgrel = 0
url = https://github.com/vicr123/theshell
arch = x86_64
license = GPL3
- makedepends = git
depends = kwidgetsaddons
depends = xdg-utils
depends = wmctrl
@@ -27,8 +26,7 @@ pkgbase = theshell
conflicts = ts-polkitagent
replaces = ts-startsession
replaces = ts-polkitagent
- source = theshell-8.0.1::git+https://github.com/vicr123/theshell#branch=master
- md5sums = SKIP
+ source = https://github.com/vicr123/theshell/archive/refs/tags/v8.0.2.tar.gz
+ sha256sums = 00bf5d9838eae954f505143a6530d13f67938d0d3a7c5333971e4cb1b50cc615
pkgname = theshell
-
diff --git a/PKGBUILD b/PKGBUILD
index 27e563d39ac6..c6c4f578fdb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theshell
-pkgver=8.0.1
+pkgver=8.0.2
pkgrel=0
pkgdesc="Desktop Shell that gets out of your way"
arch=("x86_64")
@@ -12,11 +12,10 @@ depends=('kwidgetsaddons' 'xdg-utils' 'wmctrl' 'kwin'
'libcups' 'qt5-base' 'ts-qtplatform' 'qt5-charts'
'qt5-location' 'kscreen' 'ts-bt' 'ts-bugreport')
optdepends=('alsa-utils: for volume controls')
-makedepends=('git')
conflicts=('ts-startsession' 'ts-polkitagent')
replaces=('ts-startsession' 'ts-polkitagent')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theshell#branch=master')
-md5sums=('SKIP')
+source=('https://github.com/vicr123/theshell/archive/refs/tags/v8.0.2.tar.gz')
+sha256sums=('00bf5d9838eae954f505143a6530d13f67938d0d3a7c5333971e4cb1b50cc615')
build() {
cd "$pkgname-$pkgver"
@@ -26,5 +25,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make install INSTALL_ROOT=$pkgdir
+ make -i install INSTALL_ROOT=$pkgdir
+ chmod u+s $pkgdir/usr/lib/ts-mousepass-change
}