summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Platte2015-07-22 21:34:06 +0200
committerJonas Platte2015-07-22 21:34:06 +0200
commitd701525a06bff743050ee851e59e99666ad1bf4b (patch)
tree400b55fb9344f188cb2587698dfbe216672454ed /PKGBUILD
parent9f605cd3c2284ae5b0e8d2d23901b3e2de892e57 (diff)
downloadaur-tntnet-git.tar.gz
Upstream uses git tags now, fix pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6153c734e5e..f749f0f625e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jonas Platte <aur@jonasplatte.de>
pkgname=tntnet-git
-pkgver=2.3.pre1.b824f78
-pkgrel=2
+pkgver=2.3rc1.r4.g6c10627
+pkgrel=1
pkgdesc="A modular, multithreaded, high performance webapplication server for C++"
arch=('i686' 'x86_64')
url="http://www.tntnet.org/tntnet.html"
@@ -16,11 +16,9 @@ backup=('etc/tntnet/tntnet.xml')
source=("$pkgname::git+https://github.com/maekitalo/${pkgname%-git}.git")
sha256sums=('SKIP')
-# This will very likely break if tntnet starts using tags. That is intentional,
-# as the --always will be removed then anyway, requiring an update
pkgver() {
cd "$pkgname"
- echo "2.3.pre1.$(git describe --always)"
+ git describe --long | sed 's/^V//' | sed 's/-/.r/;s/-/./'
}
build() {