summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera Micó2024-01-06 22:47:55 +0000
committerJoan Bruguera Micó2024-01-06 22:48:26 +0000
commit43c1896215a604c6c9dca2c4cb317c5d80b2630d (patch)
tree5fc8a388c32fe2bfe48b106bebe48b357489612e /PKGBUILD
parente8fb4e5c64be0b35161544f685a5f0d646828799 (diff)
downloadaur-todoist-full-offline-backup.tar.gz
Do a PEP 517 build instead of running setup.py
Fixes the "Please avoid running ``setup.py`` directly." warning. See: https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c61f125b1ae..45ab60519be9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,21 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname=full-offline-backup-for-todoist
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Small, dependency-less Python script to make a backup of all Todoist tasks and attachments that is accessible offline"
arch=('any')
url="https://github.com/joanbm/full-offline-backup-for-todoist"
license=('GPLv3')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/joanbm/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('bf40d32d26d785b424a08a15e415987cc44547032c396338d4f19a66060eaba0')
+build() {
+ cd "${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
check() {
cd "${pkgname}-${pkgver}"
python -m unittest
@@ -18,5 +23,5 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}