summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-15 11:44:13 -0500
committerCarlos Aznarán Laos2022-03-15 11:44:13 -0500
commitf3a372e6374339693a9ee0265061121a6ab0b039 (patch)
tree39131da4ae544a3c9e13af04953a1517ab33a2c7 /PKGBUILD
parentc192b83ab3f5650fb8eab5df4af933d0c1d1ed8b (diff)
downloadaur-tokyocabinet-git.tar.gz
Fix git sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 16 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bffa0b0e31a8..3109da53e6ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,40 @@
-# Maintainer: Vincent Bernardoff <vb@luminar.eu.org>
+# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
# Contributor: Mark Foxwell <fastfret79@archlinux.org.uk>
# Contributor: Nicolas Martyanoff <khaelin@gmail.com>
# Contributor: Rick Chen <stuffcorpse@archlinux.us>
-
-pkgname=tokyocabinet-git
-pkgver=1.4.48.r15.gd303368
+_base=tokyocabinet
+pkgname=${_base}-git
+pkgver=1.4.48.r20.g6d4cc70
pkgrel=1
pkgdesc="a modern implementation of DBM"
arch=('i686' 'x86_64' 'armv7h')
-url="http://fallabs.com/tokyocabinet/"
-license=('LGPL')
-makedepends=('gcc>=3.1' 'make' 'pkgconfig' 'git')
-depends=('zlib' 'bzip2')
-source=("$pkgname"::'git+git://github.com/Incubaid/tokyocabinet')
-conflicts=('tokyocabinet')
-provides=('tokyocabinet=1.4.48')
-md5sums=('SKIP')
+url="http://fallabs.com/${_base}"
+license=(LGPL)
+depends=(zlib bzip2)
+makedepends=(gcc make pkgconfig git)
+source=(git+https://github.com/Incubaid/${_base})
+conflicts=(${_base})
+provides=("${_base}=1.4.48")
+sha512sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd ${_base}
git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$pkgname"
+ cd ${_base}
./configure --prefix=/usr --enable-off64
make
}
# uncomment check routine if needed (can take ~5mins to run check)
# check() {
-# cd "$srcdir/$pkgname"
+# cd ${_base}
# make -k check
# }
package() {
- cd "$srcdir/$pkgname"
+ cd ${_base}
make DESTDIR="$pkgdir/" install
}
-
-# vim:set ts=2 sw=2 et: