summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhys Perry2024-01-25 11:59:16 +0000
committerRhys Perry2024-01-25 11:59:16 +0000
commit2eb199b4859fee4f5b86b0c212da3c5192c7390c (patch)
tree2f900752aeaa732103e90fed14baf61c259aeace /PKGBUILD
parent72535d42faf1620173ef2526d1528bbc52bbf740 (diff)
downloadaur-ubertooth-git.tar.gz
Clean PKGBUILD, apply patch to fix building with later setuptools versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae415ff373aa..12742184ba6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@
_gitname=ubertooth
pkgname=ubertooth-git
-pkgver=2020.12.R1.r33.ge0fd34d
+pkgver=2020.12.R1.r34.g0aae62e
pkgrel=2
-pkgdesc="open source wireless development platform suitable for Bluetooth experimentation"
-url="https://github.com/greatscottgadgets/ubertooth"
+pkgdesc='open source wireless development platform suitable for Bluetooth experimentation'
+url='https://github.com/greatscottgadgets/ubertooth'
+provides=('ubertooth')
+conflicts=('ubertooth')
arch=('x86_64' 'i686')
license=('GPL2')
depends=('libbtbb-git' 'libusb' 'libpcap' 'python' 'python-libusb1')
makedepends=('git' 'cmake' 'python-setuptools')
-source=(git+https://github.com/greatscottgadgets/ubertooth/)
-md5sums=('SKIP')
+source=('git+https://github.com/greatscottgadgets/ubertooth/' 'specan-version.patch::https://github.com/greatscottgadgets/ubertooth/commit/6fb9858b3d3daf511f70cb7c5db2b6316031972a.patch')
+md5sums=('SKIP' 'a85952153d7e1f233d790a2bf363ce80')
pkgver() {
@@ -20,6 +22,11 @@ pkgver() {
git describe --tags --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_gitname"
+ git am "$srcdir/specan-version.patch"
+}
+
build() {
cd "$_gitname/host/"
mkdir -p build