summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwcampbell2019-10-14 21:54:33 -0400
committerwcampbell2019-10-14 21:54:33 -0400
commit88e7eb687c82202d2cfc90e9c020e62ccbc75975 (patch)
tree906e230243833e50cf4fb09a7755f46443c38442 /PKGBUILD
downloadaur-usb-notify-git.tar.gz
Initial Commit
Signed-off-by: wcampbell <wcampbell1995@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf6591a7b18f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Wayne Campbell <wcampbell1995 [at] gmail [dot] com>
+pkgname=usb-notify-git
+_pkgname=usb-notify
+pkgver=v0.1.1.r0.gb4d0ffb
+pkgrel=1
+pkgdesc="Notification Daemon for usb events"
+arch=('any')
+url="https://github.com/userWayneCampbell/usb-notify"
+license=('GPL')
+depends=('libnotify')
+source=("git+https://github.com/userWayneCampbell/usb-notify.git")
+md5sums=('SKIP')
+
+# Support without tags and with tags
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make && sudo make install
+}