summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaizhao Zhang2020-05-11 13:17:22 +0800
committerKaizhao Zhang2020-05-11 13:17:22 +0800
commit8df848571cb68bd116c5c38568b8451bae64baba (patch)
tree4b0f49683036ac862f17825922c82696a395b18a /PKGBUILD
parent670c5e32521b6af9d23891215d068e2bae986738 (diff)
downloadaur-uvicorn.tar.gz
Updated to version 0.11.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e4eb41047c6..8032d266c421 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=uvicorn
-pkgver=0.11.3
-pkgrel=2
+pkgver=0.11.5
+pkgrel=1
pkgdesc="The lightning-fast ASGI server."
arch=('any')
url="https://www.uvicorn.org/"
@@ -10,21 +10,26 @@ license=('BSD')
depends=(
'python>=3.6'
'python-click>=7.0'
- 'python-h11>=0.8.0'
+ 'python-click<8.0'
+ 'python-h11>=0.8'
+ 'python-h11<0.10'
'python-httptools>=0.1.0'
+ 'python-httptools<0.2.0'
'python-uvloop>=0.14.0'
'python-websockets>=8.0'
+ 'python-websockets<9.0'
)
makedepends=('python-setuptools')
optdepends=(
- 'python-watchdog>=0.6: for watchdogreload support'
+ 'python-watchdog>=0.6: watchdogreload support'
+ 'python-watchdog<0.7: watchdogreload support'
)
options=(!emptydirs)
source=(
"https://github.com/encode/uvicorn/archive/${pkgver}.tar.gz"
)
sha256sums=(
- 'b19934169d8e032c06f372883d941c324f10187b147c6b33a12f464a3f63eeae'
+ 'be40828a1cdabbc9fccf90b2d846f866f2c5e846e3ef7f75101cb3c76e9fc2df'
)
build() {