summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 18:44:15 +0100
committersL1pKn072022-03-13 18:44:15 +0100
commit71d38b5966a7a104743cd104c0dcdaf5007d3c54 (patch)
treee82e38959ff469252db0f88d881c21eeceacf669 /PKGBUILD
parent4361342e32c7d6201c0ee876700627f9a2416fbe (diff)
downloadaur-vapoursynth-plugin-videoscope-git.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7112cd4c9e61..8d2dc971ba01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=videoscope
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.2.g527b9b0
+pkgver=1.0.2.g527b9b0
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -17,22 +17,23 @@ source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git"
sha256sums=('SKIP'
'0356258391e190dc1d44ea01565cfe627fe44e27dad693a0a54c2483a7b223e5'
)
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth