summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosh Holmer2021-10-02 08:03:01 -0400
committerJosh Holmer2021-10-02 08:03:01 -0400
commit2abab2be5e2cc1f6517a42b7dfadfd0188f057de (patch)
treeb7ee0a9ab21dc13ce796a71b6ba77497183edb8c /PKGBUILD
downloadaur-vapoursynth-plugin-vivtc-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd3d2e31b723
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Joshua Holmer <jholmer.in@gmail.com>
+
+_plug=vivtc
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=R1.2.ged56d96
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/vapoursynth/vivtc'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/vapoursynth/vivtc.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" --libdir /usr/lib/vapoursynth
+ ninja
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/docs/vivtc.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+}