summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-01-29 09:33:12 -0700
committerMark Wagie2024-01-29 09:33:12 -0700
commita3b5e54e76b512b1471429ce347a5730dc47fc47 (patch)
tree92fbeba597232ab9cbab0880e55f6fa7c18e6853 /PKGBUILD
parentc43dadc4d542903ba797fcb5984e0607f89a9be4 (diff)
downloadaur-vulkan-caps-viewer-x11.tar.gz
3.33
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a1465039492..2e7549a13d30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Co-Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=vulkan-caps-viewer-x11
-pkgver=3.32
+pkgver=3.33
pkgrel=1
epoch=1
pkgdesc="Vulkan Hardware Capability Viewer"
@@ -12,26 +12,26 @@ depends=('vulkan-icd-loader' 'qt5-x11extras')
makedepends=('git')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-_commit=3024e3148a7b47706b6d259f8e0ad0a2aa651330 # tags/3.32^0
+_commit=1008cecb054ab15acf51353ac85ffd8ebb135cc4 # tags/3.33^0
source=("git+https://github.com/SaschaWillems/VulkanCapsViewer.git#commit=$_commit"
'git+https://github.com/KhronosGroup/Vulkan-Headers.git')
sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/VulkanCapsViewer"
+ cd VulkanCapsViewer
git describe --tags | sed 's/_fixed//;s/-/+/g'
}
prepare() {
- cd "$srcdir/VulkanCapsViewer"
+ cd VulkanCapsViewer
git submodule init
git config submodule.Vulkan-Headers.url "$srcdir/Vulkan-Headers"
git -c protocol.file.allow=always submodule update
}
build() {
- cd "$srcdir/VulkanCapsViewer"
+ cd VulkanCapsViewer
qmake-qt5 \
DEFINES+=X11 \
CONFIG+=release \
@@ -40,7 +40,7 @@ build() {
}
package() {
- cd "$srcdir/VulkanCapsViewer"
+ cd VulkanCapsViewer
make INSTALL_ROOT="$pkgdir/" install
# There's a bug preventing this from being installed automatically