summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2016-09-21 17:37:29 +0200
committeranthraxx2016-09-21 17:37:29 +0200
commit1c95d68676321420fcf6c97a1652e2019ee8917e (patch)
tree098fa729c138f62e13165a2c0ac18101105bc177 /PKGBUILD
parentf64ad7a45ae2edf29285201356fe07f291118ef9 (diff)
downloadaur-vundle-git.tar.gz
upgpkg: vundle-git 0.10.2.605.fef1c2f-1 (switch url, remove legacy vimrc)
- upstream release - using new vundle upstream url - removed legacy vimrc as its properly documented in the README
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38b25143b798..7a813cc903e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Fat Cat <carlos dot manuel250 at gmail dot com>
pkgname=vundle-git
-pkgver=0.10.2.580.cfd3b2d
+pkgver=0.10.2.605.fef1c2f
pkgrel=1
-pkgdesc="Plug-in manager for Vim"
-url="https://github.com/gmarik/Vundle.vim"
+pkgdesc='Plug-in manager for Vim'
+url='https://github.com/VundleVim/Vundle.vim'
arch=('any')
license=('MIT')
depends=('vim>=7.0')
@@ -13,26 +13,31 @@ makedepends=('git')
provides=('vundle')
conflicts=('vundle')
install=vundle.install
-source=(${pkgname}::git+https://github.com/gmarik/Vundle.vim
- vundle.vimrc)
-sha512sums=('SKIP'
- '73329b4a1f302c684a6c203faac11ca040fd549ed4b4a5b09f4d94c53315748478e3b079bd4d2aed648e4eece2e62fd99d21ffcd34eb966e9e840ef73647c5fb')
+source=(${pkgname}::git+https://github.com/VundleVim/Vundle.vim)
+sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- printf "%s.%s.%s" "$(git describe --tags --abbrev=0|sed 's/^v//')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.%s.%s" \
+ "$(git describe --tags --abbrev=0|sed 's/^v//')" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ sed -r 's|(set rtp)|" \1|' -i README.md
}
package() {
cd ${pkgname}
vimpath="${pkgdir}/usr/share/vim/vimfiles"
- mkdir -p ${vimpath}/doc
- cp -R doc ${vimpath}
- mkdir -p ${vimpath}/autoload
- cp -R autoload ${vimpath}
+ mkdir -p "${vimpath}/doc"
+ cp -R doc "${vimpath}"
+ mkdir -p "${vimpath}/autoload"
+ cp -R autoload "${vimpath}"
- install -Dm 644 "${srcdir}"/vundle.vimrc "${pkgdir}/usr/share/vundle/vimrc.sample"
install -Dm 644 LICENSE-MIT.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
}