summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Dray2016-03-29 13:41:53 +1000
committerJustin Dray2016-03-29 13:41:53 +1000
commite2db90ec4159c5e2055630d4c1a6552d183ad4dd (patch)
treebca8ba15e0661abde74a3d20d3fedba90adb9ab1 /PKGBUILD
downloadaur-wemux.tar.gz
Update to: 3.2.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f8465f45736
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Tristan Webb <tristanjwebb@gmail.com>
+pkgname=wemux
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Multi-user Tmux made easy"
+url="https://github.com/zolrath/wemux"
+arch=('any')
+license=('MIT')
+depends=('tmux' 'lsof' 'openssh')
+backup=('etc/wemux/wemux.conf')
+install='wemux.install'
+md5sums=('c83c5ee88d3784d79449c05a8e55da70')
+source=("https://github.com/zolrath/wemux/archive/v${pkgver}.zip")
+
+package(){
+ cd wemux-$pkgver
+ install -dm755 $pkgdir/usr/share
+
+ sed -i -e "s|usr/local/etc|etc/wemux|g" ./wemux
+
+ #install manpage
+ install -Dm644 ./man/wemux.1 $pkgdir/usr/share/man/man1/wemux.1
+
+
+ #install binary and readme
+ install -Dm755 ./wemux $pkgdir/usr/bin/wemux
+ install -Dm644 ./README.md $pkgdir/usr/share/wemux/README.md
+
+ #install conf
+ install -Dm644 ./wemux.conf.example $pkgdir/etc/wemux/wemux.conf
+
+ #install licence
+ install -Dm644 ./MIT-LICENSE $pkgdir/usr/share/licenses/wemux/LICENSE
+
+}
+
+# vim:set ts=2 sw=2 et: