summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordreieck2023-04-13 22:09:11 +0200
committerdreieck2023-04-13 22:09:11 +0200
commitc8f32394b4eff05816e9901c59ee440cdfc8a85a (patch)
treee76bd2500e85d2789db9622957ea6f9adc075136 /PKGBUILD
parente6b723b50dbd6e902b3fca8994e0199e6b7e49c0 (diff)
downloadaur-widelands-maps-rttr-localver.tar.gz
Fixed symlinks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bf1126ad4ed..88f33f214e91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@ pkgname="${_pkgname}-localver"
pkgdesc="Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands."
url='http://siedler25.org/'
arch=('any')
-pkgver=r3946.826300c2
-pkgrel=3
+pkgver=v0.9.5.85
+pkgrel=2
depends=('return-to-the-roots')
makedepends=('return-to-the-roots') # Needed for pkgver()
optdepends=('widelands: To play the maps with widelands.')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
+replaces=()
license=('GPL2')
options+=('emptydirs')
source=()
@@ -19,13 +20,10 @@ sha256sums=()
pkgver() {
# Set the pkgver to that of the installed return-to-the-root.
- pacman -Qi return-to-the-roots | grep -E '^Version' | head -n 1 | awk -F ':' '{print $2}' | awk -F '-' '{print $1}' | tr -d '[[:space:]]'
+ pacman -Q return-to-the-roots | awk '{print $2}' | sed 's|-.*||'
}
package() {
- install -v -m755 -d "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
- cd "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
- ln -sv "/usr/share/s25rttr/RTTR/MAPS/NEW" "Newer maps"
- ln -sv "/usr/share/s25rttr/RTTR/MAPS/OTHER" "Other maps"
- ln -sv "/usr/share/s25rttr/RTTR/MAPS/SEA" "Seafearing maps"
+ install -d -v -m755 "${pkgdir}/usr/share/widelands/maps"
+ ln -svr "${pkgdir}/usr/share/s25rttr/RTTR/MAPS" "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
}