summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTyler Veness2023-12-11 21:23:05 -0800
committerTyler Veness2023-12-22 12:49:01 -0800
commit364d92719143bd948ad543c475a09fde54a59dc3 (patch)
tree427f6810153b3bd688e03ffe1a87117292a2994d /PKGBUILD
parent18e43935af9d147f2f5f38f4d6f33160a2a9fa12 (diff)
downloadaur-wpimath-git.tar.gz
Replace -Werror removal patch with -DNO_WERROR flag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 717e6e86cbfb..3b06cd53ef03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tyler Veness <calcmogul at gmail dot com>
pkgname=wpimath-git
-pkgver=2024.1.1.beta.1.r29.gabb2857e03
+pkgver=2024.1.1.beta.4.r20.gd1793f077d
pkgrel=1
pkgdesc="WPILib's mathematics and controls library"
arch=('x86_64')
@@ -12,10 +12,8 @@ provides=('wpimath')
conflicts=('wpimath')
license=('BSD' 'MIT')
options=('!strip' 'staticlibs')
-source=('git+https://github.com/wpilibsuite/allwpilib'
- 'Don_t-treat-warnings-as-errors.patch')
-md5sums=('SKIP'
- '06355c12d930efa26edbbe11f633831a')
+source=('git+https://github.com/wpilibsuite/allwpilib')
+md5sums=('SKIP')
pkgver() {
cd allwpilib
@@ -25,11 +23,6 @@ pkgver() {
)
}
-prepare() {
- cd allwpilib
- patch -p1 < "$srcdir"/Don_t-treat-warnings-as-errors.patch
-}
-
build() {
cmake -B build -S "allwpilib" \
-DCMAKE_INSTALL_PREFIX='/usr' \
@@ -43,6 +36,7 @@ build() {
-DWITH_TESTS=ON \
-DWITH_GUI=OFF \
-DWITH_SIMULATION_MODULES=OFF \
+ -DNO_WERROR=ON \
-Wno-dev
cmake --build build
}