summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHauke Rehfeld2020-04-13 21:24:38 +0200
committerHauke Rehfeld2020-04-13 21:24:38 +0200
commit687a9870dad1ab1f1cead06aec11df88aafc783f (patch)
tree33fa1cdb6c05e15152d8031eaaa7280c47301686 /PKGBUILD
downloadaur-xrandr-multihead-bottom-git.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cde0c6dedbd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Hauke Rehfeld <aur.archlinux.org@haukerehfeld.de>
+pkgname=xrandr-multihead-bottom-git
+pkgver=r2.ee61e56
+pkgrel=1
+pkgdesc="Align a bunch of screens to the bottom edge left to right via a xrandr call."
+arch=('x86_64' 'i686')
+depends=('xorg-xrandr')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+url="https://github.com/hrehfeld/xrandr-multihead-bottom"
+source=("git+${url}.git")
+noextract=()
+md5sums=("SKIP")
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git checkout master
+}
+
+package() {
+ install -Dm755 "$srcdir/${pkgname%-git}/xrandr-multihead-bottom" "$pkgdir/usr/bin/xrandr-multihead-bottom"
+}